summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb')
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb48
1 files changed, 18 insertions, 30 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
index 0b42d58fe3..20e4942835 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
@@ -17,7 +17,6 @@ LIC_FILES_CHKSUM:append = " ${@bb.utils.contains('PACKAGECONFIG', 'arm-neon', 'f
17PROVIDES = "virtual/libsdl2" 17PROVIDES = "virtual/libsdl2"
18 18
19SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \ 19SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
20 file://more-gen-depends.patch \
21 file://0001-Fix-build-against-wayland-1.20.patch \ 20 file://0001-Fix-build-against-wayland-1.20.patch \
22" 21"
23 22
@@ -25,20 +24,19 @@ S = "${WORKDIR}/SDL2-${PV}"
25 24
26SRC_URI[sha256sum] = "94d40cd73dbfa10bb6eadfbc28f355992bb2d6ef6761ad9d4074eff95ee5711c" 25SRC_URI[sha256sum] = "94d40cd73dbfa10bb6eadfbc28f355992bb2d6ef6761ad9d4074eff95ee5711c"
27 26
28inherit autotools lib_package binconfig-disabled pkgconfig 27inherit cmake lib_package binconfig-disabled pkgconfig
29 28
30BINCONFIG = "${bindir}/sdl2-config" 29BINCONFIG = "${bindir}/sdl2-config"
31 30
32CVE_PRODUCT = "simple_directmedia_layer sdl" 31CVE_PRODUCT = "simple_directmedia_layer sdl"
33 32
34EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \ 33EXTRA_OECMAKE = "-DSDL_OSS=OFF -DSDL_ESD=OFF -DSDL_ARTS=OFF \
35 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ 34 -DSDL_DISKAUDIO=OFF -DSDL_NAS=OFF -DSDL_ESD_SHARED=OFF \
36 --disable-video-dummy \ 35 -DSDL_DUMMYVIDEO=OFF \
37 --disable-video-rpi \ 36 -DSDL_RPI=OFF \
38 --enable-pthreads \ 37 -DSDL_PTHREADS=ON \
39 --disable-rpath \ 38 -DSDL_RPATH=OFF \
40 --disable-sndio \ 39 -DSDL_SNDIO=OFF \
41 --disable-fcitx --disable-ibus \
42 " 40 "
43 41
44# opengl packageconfig factored out to make it easy for distros 42# opengl packageconfig factored out to make it easy for distros
@@ -53,27 +51,17 @@ PACKAGECONFIG ??= " \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \ 51 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \
54 ${@bb.utils.contains("TUNE_FEATURES", "neon","arm-neon","",d)} \ 52 ${@bb.utils.contains("TUNE_FEATURES", "neon","arm-neon","",d)} \
55" 53"
56PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," 54PACKAGECONFIG[alsa] = "-DSDL_ALSA=ON,-DSDL_ALSA=OFF,alsa-lib,"
57PACKAGECONFIG[arm-neon] = "--enable-arm-neon,--disable-arm-neon" 55PACKAGECONFIG[arm-neon] = "-DSDL_ARMNEON=ON,-DSDL_ARMNEON=OFF"
58PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb,directfb" 56PACKAGECONFIG[directfb] = "-DSDL_DIRECTFB=ON,-DSDL_DIRECTFB=OFF,directfb,directfb"
59PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2" 57PACKAGECONFIG[gles2] = "-DSDL_OPENGLES=ON,-DSDL_OPENGLES=OFF,virtual/libgles2"
60PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" 58PACKAGECONFIG[jack] = "-DSDL_JACK=ON,-DSDL_JACK=OFF,jack"
61PACKAGECONFIG[kmsdrm] = "--enable-video-kmsdrm,--disable-video-kmsdrm,libdrm virtual/libgbm" 59PACKAGECONFIG[kmsdrm] = "-DSDL_KMSDRM=ON,-DSDL_KMSDRM=OFF,libdrm virtual/libgbm"
62PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl" 60PACKAGECONFIG[opengl] = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/libgl"
63PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" 61PACKAGECONFIG[pulseaudio] = "-DSDL_PULSEAUDIO=ON,-DSDL_PULSEAUDIO=OFF,pulseaudio"
64PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon" 62PACKAGECONFIG[wayland] = "-DSDL_WAYLAND=ON,-DSDL_WAYLAND=OFF,wayland-native wayland wayland-protocols libxkbcommon"
65PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender" 63PACKAGECONFIG[x11] = "-DSDL_X11=ON,-DSDL_X11=OFF,virtual/libx11 libxext libxrandr libxrender"
66 64
67EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
68CFLAGS:append:class-native = " -DNO_SHARED_MEMORY" 65CFLAGS:append:class-native = " -DNO_SHARED_MEMORY"
69 66
70do_configure:prepend() {
71 # Remove old libtool macros.
72 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
73 for i in ${MACROS}; do
74 rm -f ${S}/acinclude/$i
75 done
76 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
77}
78
79BBCLASSEXTEND = "native nativesdk" 67BBCLASSEXTEND = "native nativesdk"