summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl2/libsdl2_2.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.1.bb')
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.1.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.1.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.1.bb
new file mode 100644
index 0000000000..7958f7b985
--- /dev/null
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.1.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "Zlib"
11LIC_FILES_CHKSUM = "file://COPYING.txt;md5=0605ca7e995ab1217e0bb988731a87fe"
12
13PROVIDES = "virtual/libsdl2"
14
15DEPENDS = "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
16 ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} \
17 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxext libxrandr libxrender', '', d)} \
18 tslib"
19DEPENDS_class-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}"
20
21SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
22 "
23
24S = "${WORKDIR}/SDL2-${PV}"
25
26SRC_URI[md5sum] = "0eb97039488bf463e775295f7b18b227"
27SRC_URI[sha256sum] = "0ae7e902a26777614a011fe7053ca7e8b14843db3c42ca117564d208cf6732f0"
28
29inherit autotools lib_package binconfig pkgconfig
30
31EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
32 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
33 --disable-video-dummy \
34 --enable-input-tslib --enable-pthreads \
35 ${@base_contains('DISTRO_FEATURES', 'directfb', '--enable-video-directfb', '--disable-video-directfb', d)} \
36 ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-video-opengl', '--disable-video-opengl', d)} \
37 ${@base_contains('DISTRO_FEATURES', 'x11', '--enable-video-x11', '--disable-video-x11', d)} \
38 --enable-sdl-dlopen \
39 --disable-rpath \
40 --disable-pulseaudio"
41
42PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
43PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
44
45PARALLEL_MAKE = ""
46
47EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
48
49do_configure_prepend() {
50 # Remove old libtool macros.
51 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
52 for i in ${MACROS}; do
53 rm -f ${S}/acinclude/$i
54 done
55 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
56}