summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl/libsdl_1.2.15.bb')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb74
1 files changed, 0 insertions, 74 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
deleted file mode 100644
index 7718d11919..0000000000
--- a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
+++ /dev/null
@@ -1,74 +0,0 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "LGPLv2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
12
13PROVIDES = "virtual/libsdl"
14
15PR = "r3"
16
17SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
18 file://libsdl-1.2.15-xdata32.patch \
19 file://pkgconfig.patch \
20 file://0001-build-Pass-tag-CC-explictly-when-using-libtool.patch \
21 "
22
23UPSTREAM_CHECK_REGEX = "SDL-(?P<pver>\d+(\.\d+)+)\.tar"
24
25S = "${WORKDIR}/SDL-${PV}"
26
27SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85"
28SRC_URI[sha256sum] = "d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00"
29
30BINCONFIG = "${bindir}/sdl-config"
31
32inherit autotools lib_package binconfig-disabled pkgconfig
33
34CVE_PRODUCT = "simple_directmedia_layer sdl"
35
36EXTRA_OECONF = "--disable-static --enable-cdrom --enable-threads --enable-timers \
37 --enable-file --disable-oss --disable-esd --disable-arts \
38 --disable-diskaudio --disable-nas \
39 --disable-mintaudio --disable-nasm --disable-video-dga \
40 --disable-video-fbcon --disable-video-ps2gs --disable-video-ps3 \
41 --disable-xbios --disable-gem --disable-video-dummy \
42 --enable-input-events --enable-pthreads \
43 --disable-video-svga \
44 --disable-video-picogui --disable-video-qtopia --enable-sdl-dlopen \
45 --disable-rpath"
46
47PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \
48 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)}"
49PACKAGECONFIG_class-native = "x11"
50PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
51
52PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib"
53PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
54PACKAGECONFIG[tslib] = "--enable-input-tslib, --disable-input-tslib, tslib"
55PACKAGECONFIG[directfb] = "--enable-video-directfb, --disable-video-directfb, directfb"
56PACKAGECONFIG[opengl] = "--enable-video-opengl, --disable-video-opengl, virtual/libgl libglu"
57PACKAGECONFIG[x11] = "--enable-video-x11 --disable-x11-shared, --disable-video-x11, virtual/libx11 libxext libxrandr libxrender"
58
59# The following two options should only enabled with mingw support
60PACKAGECONFIG[stdio-redirect] = "--enable-stdio-redirect,--disable-stdio-redirect"
61PACKAGECONFIG[directx] = "--enable-directx,--disable-directx"
62
63EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
64
65do_configure_prepend() {
66 # Remove old libtool macros.
67 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
68 for i in ${MACROS}; do
69 rm -f ${S}/acinclude/$i
70 done
71 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
72}
73
74BBCLASSEXTEND = "native nativesdk"