summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libepoxy/libepoxy_1.5.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libepoxy/libepoxy_1.5.5.bb')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_1.5.5.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_1.5.5.bb b/meta/recipes-graphics/libepoxy/libepoxy_1.5.5.bb
new file mode 100644
index 0000000000..a404fe2852
--- /dev/null
+++ b/meta/recipes-graphics/libepoxy/libepoxy_1.5.5.bb
@@ -0,0 +1,32 @@
1SUMMARY = "OpenGL function pointer management library"
2DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \
3glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \
4very little knowledge needed on their part. They get to read GL specs and \
5write code using undecorated function names like glCompileShader()."
6HOMEPAGE = "https://github.com/anholt/libepoxy/"
7SECTION = "libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
11
12SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
13 file://0001-dispatch_common.h-define-also-EGL_NO_X11.patch \
14 "
15SRC_URI[sha256sum] = "261663db21bcc1cc232b07ea683252ee6992982276536924271535875f5b0556"
16UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
17
18inherit meson pkgconfig features_check
19
20REQUIRED_DISTRO_FEATURES = "opengl"
21
22PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
23PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl"
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
25
26EXTRA_OEMESON += "-Dtests=false"
27
28PACKAGECONFIG_class-native = "egl x11"
29PACKAGECONFIG_class-nativesdk = "egl x11"
30
31BBCLASSEXTEND = "native nativesdk"
32