summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb b/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb
new file mode 100644
index 0000000000..92f644c039
--- /dev/null
+++ b/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb
@@ -0,0 +1,22 @@
1SUMMARY = "OpenGL function pointer management library"
2HOMEPAGE = "https://github.com/anholt/libepoxy/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
7
8SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
9 "
10SRC_URI[md5sum] = "e2845de8d2782b2d31c01ae8d7cd4cbb"
11SRC_URI[sha256sum] = "002958c5528321edd53440235d3c44e71b5b1e09b9177e8daf677450b6c4433d"
12UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
13
14inherit meson pkgconfig distro_features_check
15
16REQUIRED_DISTRO_FEATURES = "opengl"
17
18PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
19PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no, virtual/libx11 virtual/libgl"
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
21
22EXTRA_OEMESON += "-Dtests=false"