summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libepoxy/libepoxy_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libepoxy/libepoxy_1.5.0.bb')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_1.5.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_1.5.0.bb b/meta/recipes-graphics/libepoxy/libepoxy_1.5.0.bb
new file mode 100644
index 0000000000..dfdd19248d
--- /dev/null
+++ b/meta/recipes-graphics/libepoxy/libepoxy_1.5.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "OpenGL function pointer management library"
2HOMEPAGE = "https://github.com/anholt/libepoxy/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
7
8SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
9 file://0001-Make-it-possible-to-disable-the-use-of-dlvsym-needed.patch \
10 "
11SRC_URI[md5sum] = "63fe3847789258254dcd7e3fdb9e7f5e"
12SRC_URI[sha256sum] = "4c94995398a6ebf691600dda2e9685a0cac261414175c2adf4645cdfab42a5d5"
13UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
14
15inherit meson pkgconfig distro_features_check
16
17REQUIRED_DISTRO_FEATURES = "opengl"
18
19DEPENDS = "util-macros"
20
21PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
22PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no, virtual/libx11 virtual/libgl"
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
24
25EXTRA_OEMESON_append_libc-musl = " -Dhas-dlvsym=false "