summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libepoxy/libepoxy_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libepoxy/libepoxy_1.4.1.bb')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_1.4.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_1.4.1.bb b/meta/recipes-graphics/libepoxy/libepoxy_1.4.1.bb
new file mode 100644
index 0000000000..4b3f56a255
--- /dev/null
+++ b/meta/recipes-graphics/libepoxy/libepoxy_1.4.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "OpenGL function pointer management library"
2HOMEPAGE = "https://github.com/anholt/libepoxy/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
7
8SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz"
9SRC_URI[md5sum] = "a0dc66910009a99c47c5def50b042d77"
10SRC_URI[sha256sum] = "88c6abf5522fc29bab7d6c555fd51a855cbd9253c4315f8ea44e832baef21aa6"
11UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
12
13inherit autotools pkgconfig distro_features_check
14
15REQUIRED_DISTRO_FEATURES = "opengl"
16
17DEPENDS = "util-macros virtual/egl"
18
19PACKAGECONFIG[x11] = "--enable-glx, --disable-glx, virtual/libx11"
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"