diff options
Diffstat (limited to 'meta/recipes-graphics/jpeg/libjpeg-turbo_2.0.6.bb')
-rw-r--r-- | meta/recipes-graphics/jpeg/libjpeg-turbo_2.0.6.bb | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-graphics/jpeg/libjpeg-turbo_2.0.6.bb b/meta/recipes-graphics/jpeg/libjpeg-turbo_2.0.6.bb new file mode 100644 index 0000000000..b6efc6bca0 --- /dev/null +++ b/meta/recipes-graphics/jpeg/libjpeg-turbo_2.0.6.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | SUMMARY = "Hardware accelerated JPEG compression/decompression library" | ||
2 | DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression" | ||
3 | HOMEPAGE = "http://libjpeg-turbo.org/" | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=8184bcc7c4ac7b9edc6a7bc00f231d0b \ | ||
7 | file://jpeglib.h;endline=16;md5=52b5eaade8d5b6a452a7693dfe52c084 \ | ||
8 | file://djpeg.c;endline=11;md5=302e980133b5c0c7f4dcb4ca0df41090 \ | ||
9 | " | ||
10 | DEPENDS_append_x86-64_class-target = " nasm-native" | ||
11 | DEPENDS_append_x86_class-target = " nasm-native" | ||
12 | |||
13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ | ||
14 | file://0001-libjpeg-turbo-fix-package_qa-error.patch \ | ||
15 | " | ||
16 | |||
17 | SRC_URI[md5sum] = "4cada3f0bdc93d826fa31bf9e4469ef6" | ||
18 | SRC_URI[sha256sum] = "d74b92ac33b0e3657123ddcf6728788c90dc84dcb6a52013d758af3c4af481bb" | ||
19 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libjpeg-turbo/files/" | ||
20 | UPSTREAM_CHECK_REGEX = "/libjpeg-turbo/files/(?P<pver>(\d+[\.\-_]*)+)/" | ||
21 | |||
22 | PE = "1" | ||
23 | |||
24 | # Drop-in replacement for jpeg | ||
25 | PROVIDES = "jpeg" | ||
26 | RPROVIDES_${PN} += "jpeg" | ||
27 | RREPLACES_${PN} += "jpeg" | ||
28 | RCONFLICTS_${PN} += "jpeg" | ||
29 | |||
30 | inherit cmake pkgconfig | ||
31 | |||
32 | export NASMENV = "--debug-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}" | ||
33 | |||
34 | # Add nasm-native dependency consistently for all build arches is hard | ||
35 | EXTRA_OECMAKE_append_class-native = " -DWITH_SIMD=False" | ||
36 | EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_SIMD=False" | ||
37 | |||
38 | # Work around missing x32 ABI support | ||
39 | EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "-DWITH_SIMD=False", "", d)}" | ||
40 | |||
41 | # Work around missing non-floating point ABI support in MIPS | ||
42 | EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "-DWITH_SIMD=False", "", d)}" | ||
43 | |||
44 | # Provide a workaround if Altivec unit is not present in PPC | ||
45 | EXTRA_OECMAKE_append_class-target_powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" | ||
46 | EXTRA_OECMAKE_append_class-target_powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" | ||
47 | |||
48 | DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | ||
49 | DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | ||
50 | |||
51 | PACKAGES =+ "jpeg-tools libturbojpeg" | ||
52 | |||
53 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library." | ||
54 | FILES_jpeg-tools = "${bindir}/*" | ||
55 | |||
56 | DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs" | ||
57 | FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*" | ||
58 | |||
59 | BBCLASSEXTEND = "native nativesdk" | ||