summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_8.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_8.0.1.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_8.0.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_8.0.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_8.0.1.bb
new file mode 100644
index 0000000000..359272e934
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_8.0.1.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b98429b8e8e3c2a67cfef01e99e4893d \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \
9 "
10
11SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz"
12SRC_URI[sha256sum] = "c1ce780acd385569f25b9a29603d1d5bc71e6940e55bfdd4f7266fad50e42620"
13
14DEPENDS += "glib-2.0-native"
15
16inherit meson pkgconfig lib_package gtk-doc gobject-introspection github-releases
17
18GIR_MESON_ENABLE_FLAG = 'enabled'
19GIR_MESON_DISABLE_FLAG = 'disabled'
20GTKDOC_MESON_ENABLE_FLAG = 'enabled'
21GTKDOC_MESON_DISABLE_FLAG = 'disabled'
22
23PACKAGECONFIG ??= "cairo freetype glib icu"
24PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
25PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype"
26PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0"
27PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2"
28PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu"
29
30PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
31
32LEAD_SONAME = "libharfbuzz.so"
33
34do_install:append() {
35 # If no tools are installed due to PACKAGECONFIG then this directory might
36 # still be installed, so remove it to stop packaging warnings.
37 [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir}
38}
39
40FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
41FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
42 ${libdir}/libharfbuzz-icu.so \
43 ${libdir}/pkgconfig/harfbuzz-icu.pc \
44"
45FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
46
47BBCLASSEXTEND = "native nativesdk"