summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
new file mode 100644
index 0000000000..4c2d774803
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \
9 "
10
11UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
12UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
13
14SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \
15 file://0001-fix-signedness-of-char-in-tests.patch \
16 "
17SRC_URI[sha256sum] = "2edb95db668781aaa8d60959d21be2ff80085f31b12053cdd660d9a50ce84f05"
18
19inherit meson pkgconfig lib_package gtk-doc gobject-introspection
20
21GIR_MESON_ENABLE_FLAG = 'enabled'
22GIR_MESON_DISABLE_FLAG = 'disabled'
23GTKDOC_MESON_ENABLE_FLAG = 'enabled'
24GTKDOC_MESON_DISABLE_FLAG = 'disabled'
25
26PACKAGECONFIG ??= "cairo freetype glib icu"
27PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
28PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype"
29PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0"
30PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2"
31PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu"
32
33PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
34
35LEAD_SONAME = "libharfbuzz.so"
36
37do_install:append() {
38 # If no tools are installed due to PACKAGECONFIG then this directory is
39 #still installed, so remove it to stop packaging wanings.
40 rmdir --ignore-fail-on-non-empty ${D}${bindir}
41}
42
43FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
44FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
45 ${libdir}/libharfbuzz-icu.so \
46 ${libdir}/pkgconfig/harfbuzz-icu.pc \
47"
48FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
49
50BBCLASSEXTEND = "native nativesdk"