summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_2.7.4.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.7.4.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.4.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.4.bb
new file mode 100644
index 0000000000..b08f60255e
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.4.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
9
10UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
11UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
12
13SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \
14 "
15SRC_URI[sha256sum] = "6ad11d653347bd25d8317589df4e431a2de372c0cf9be3543368e07ec23bb8e7"
16
17inherit meson pkgconfig lib_package gtk-doc gobject-introspection
18
19GIR_MESON_ENABLE_FLAG = 'enabled'
20GIR_MESON_DISABLE_FLAG = 'disabled'
21GTKDOC_MESON_ENABLE_FLAG = 'enabled'
22GTKDOC_MESON_DISABLE_FLAG = 'disabled'
23
24PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
25PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
26PACKAGECONFIG[fontconfig] = "-Dfontconfig=enabled,-Dfontconfig=disabled,fontconfig"
27PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype"
28PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0"
29PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2"
30PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu"
31
32PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
33
34LEAD_SONAME = "libharfbuzz.so"
35
36do_install_append() {
37 # If no tools are installed due to PACKAGECONFIG then this directory is
38 #still installed, so remove it to stop packaging wanings.
39 rmdir --ignore-fail-on-non-empty ${D}${bindir}
40}
41
42FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
43FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
44 ${libdir}/libharfbuzz-icu.so \
45 ${libdir}/pkgconfig/harfbuzz-icu.pc \
46"
47FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
48
49BBCLASSEXTEND = "native nativesdk"