summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/graphene/graphene_1.10.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/graphene/graphene_1.10.8.bb')
-rw-r--r--meta/recipes-graphics/graphene/graphene_1.10.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
new file mode 100644
index 0000000000..e2e82b32aa
--- /dev/null
+++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
@@ -0,0 +1,29 @@
1SUMMARY = "A thin layer of graphic data types"
2HOMEPAGE = "http://ebassi.github.io/graphene/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648"
5
6
7inherit gnomebase gobject-introspection gtk-doc
8
9SRC_URI += "file://float-div.patch"
10
11SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
12
13# Disable neon support by default on ARM-32 platforms because of the
14# following upstream bug: https://github.com/ebassi/graphene/issues/215
15PACKAGECONFIG ?= "gobject-types ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
16
17PACKAGECONFIG[gobject-types] = "-Dgobject_types=true,-Dgobject_types=false,glib-2.0"
18PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
19
20GIR_MESON_ENABLE_FLAG = 'enabled'
21GIR_MESON_DISABLE_FLAG = 'disabled'
22
23GTKDOC_MESON_OPTION = "gtk_doc"
24
25EXTRA_OEMESON = "-Dinstalled_tests=false"
26
27FILES:${PN} += "${libdir}/graphene-1.0"
28
29BBCLASSEXTEND = "native nativesdk"