summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/glslang/glslang_1.3.280.0.bb')
-rw-r--r--meta/recipes-graphics/glslang/glslang_1.3.280.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb b/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
new file mode 100644
index 0000000000..637082c719
--- /dev/null
+++ b/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
10
11SRCREV = "ee2f5d09eaf8f4e8d0d598bd2172fce290d4ca60"
12SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \
13 file://0001-generate-glslang-pkg-config.patch \
14 "
15PE = "1"
16# These recipes need to be updated in lockstep with each other:
17# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
18# vulkan-validation-layers, vulkan-utility-libraries.
19# The tags versions should always be sdk-x.y.z, as this is what
20# upstream considers a release.
21UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
22S = "${WORKDIR}/git"
23
24inherit cmake python3native
25
26DEPENDS = "spirv-tools"
27
28EXTRA_OECMAKE = " \
29 -DCMAKE_BUILD_TYPE=Release \
30 -DBUILD_SHARED_LIBS=ON \
31 -DENABLE_PCH=OFF \
32 -DENABLE_CTEST=OFF \
33 -DBUILD_EXTERNAL=OFF \
34 -DALLOW_EXTERNAL_SPIRV_TOOLS=ON \
35"
36
37BBCLASSEXTEND = "native nativesdk"