summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glew/glew_1.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/glew/glew_1.13.0.bb')
-rw-r--r--meta/recipes-graphics/glew/glew_1.13.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glew/glew_1.13.0.bb b/meta/recipes-graphics/glew/glew_1.13.0.bb
new file mode 100644
index 0000000000..a25c405f3f
--- /dev/null
+++ b/meta/recipes-graphics/glew/glew_1.13.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "OpenGL extension loading library"
2DESCRIPTION = "The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source C/C++ extension loading library."
3HOMEPAGE = "http://glew.sourceforge.net/"
4BUGTRACKER = "http://sourceforge.net/tracker/?group_id=67586"
5SECTION = "x11"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ac251558de685c6b9478d89be3149c2"
8
9DEPENDS = "virtual/libx11 virtual/libgl libglu libxext libxi libxmu"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \
12 file://no-strip.patch"
13
14SRC_URI[md5sum] = "7cbada3166d2aadfc4169c4283701066"
15SRC_URI[sha256sum] = "aa25dc48ed84b0b64b8d41cdd42c8f40f149c37fa2ffa39cd97f42c78d128bc7"
16
17UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/glew/files/glew"
18UPSTREAM_CHECK_REGEX = "/glew/(?P<pver>(\d+[\.\-_]*)+)/"
19
20inherit lib_package pkgconfig distro_features_check
21
22REQUIRED_DISTRO_FEATURES = "x11"
23
24# Override SYSTEM to avoid calling config.guess, we're cross-compiling. Pass
25# our CFLAGS via POPT as that's the optimisation variable and safely
26# overwritten.
27EXTRA_OEMAKE = "SYSTEM='linux' \
28 CC='${CC}' LD='${CC}' STRIP='' \
29 LDFLAGS.EXTRA='${LDFLAGS}' \
30 POPT='${CFLAGS}' \
31 GLEW_PREFIX='${prefix}' BINDIR='${bindir}' \
32 LIBDIR='${libdir}' INCDIR='${includedir}/GL'"
33
34do_compile() {
35 oe_runmake
36}
37
38do_install() {
39 oe_runmake 'DESTDIR=${D}' install.all
40}