summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.6.3.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.3.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.3.bb b/meta/recipes-graphics/freetype/freetype_2.6.3.bb
new file mode 100644
index 0000000000..cf6882af9e
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.6.3.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
11LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
12 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
16 file://use-right-libtool.patch"
17
18SRC_URI[md5sum] = "0037b25a8c090bc8a1218e867b32beb1"
19SRC_URI[sha256sum] = "371e707aa522acf5b15ce93f11183c725b8ed1ee8546d7b3af549863045863a2"
20
21inherit autotools pkgconfig binconfig-disabled multilib_header
22
23PACKAGECONFIG ??= "zlib"
24
25PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
26# harfbuzz results in a circular dependency so enabling is non-trivial
27PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
28PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
29PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
30
31EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
32
33TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
34
35do_configure() {
36 # Need this because although the autotools infrastructure is in
37 # builds/unix the configure script get written to ${S}, so we can't
38 # just use AUTOTOOLS_SCRIPT_PATH.
39 cd ${S}/builds/unix
40 libtoolize --force --copy
41 aclocal -I .
42 gnu-configize --force
43 autoconf
44 cd ${B}
45 oe_runconf
46}
47
48do_install_append() {
49 oe_multilib_header freetype2/freetype/config/ftconfig.h
50}
51
52BINCONFIG = "${bindir}/freetype-config"
53
54BBCLASSEXTEND = "native"