summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.5.2.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.5.2.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.5.2.bb b/meta/recipes-graphics/freetype/freetype_2.5.2.bb
new file mode 100644
index 0000000000..2521b5e691
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.5.2.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9LICENSE = "FreeType | GPLv2+"
10LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=c017ff17fc6f0794adf93db5559ccd56 \
11 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14SECTION = "libs"
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
17"
18
19SRC_URI[md5sum] = "10e8f4d6a019b124088d18bc26123a25"
20SRC_URI[sha256sum] = "4ff4bd393aa01071ec7b849d035508a505a78f88b2bcf25ff11e58e43c0b9def"
21
22S = "${WORKDIR}/freetype-${PV}"
23
24inherit autotools pkgconfig binconfig
25
26LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
27EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
28EXTRA_OEMAKE_class-native = ""
29EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
30
31PACKAGECONFIG ??= ""
32PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
33
34do_configure() {
35 cd builds/unix
36 libtoolize --force --copy
37 aclocal -I .
38 gnu-configize --force
39 autoconf
40 cd ${S}
41 oe_runconf
42}
43
44do_configure_class-native() {
45 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
46 oe_runconf
47}
48
49do_compile_prepend() {
50 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
51}
52
53BBCLASSEXTEND = "native"
54