summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.15.0.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.15.0.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.15.0.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.15.0.bb
new file mode 100644
index 0000000000..b737447e47
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.15.0.bb
@@ -0,0 +1,69 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=00252fd272bf2e722925613ad74cb6c7 \
16 file://src/fcfreetype.c;endline=45;md5=ef8702fbf3dc506715be8a9d69cb0252 \
17 "
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib gperf-native util-linux"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 "
26
27SRC_URI[sha256sum] = "f5f359d6332861bd497570848fcb42520964a9e83d5e3abe397b6b6db9bcaaf4"
28
29UPSTREAM_CHECK_REGEX = "fontconfig-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
30
31do_configure:prepend() {
32 # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280
33 rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf
34}
35
36do_install:append:class-target() {
37 # duplicate fc-cache for postinstall script
38 mkdir -p ${D}${libexecdir}
39 ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache
40}
41
42do_install:append:class-nativesdk() {
43 # duplicate fc-cache for postinstall script
44 mkdir -p ${D}${libexecdir}
45 ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache
46}
47
48PACKAGES =+ "fontconfig-utils"
49FILES:${PN} =+ "${datadir}/xml/*"
50FILES:${PN}-dev += "${datadir}/gettext/*"
51FILES:fontconfig-utils = "${bindir}/* ${libexecdir}/*"
52
53# Work around past breakage in debian.bbclass
54RPROVIDES:fontconfig-utils = "libfontconfig-utils"
55RREPLACES:fontconfig-utils = "libfontconfig-utils"
56RCONFLICTS:fontconfig-utils = "libfontconfig-utils"
57DEBIAN_NOAUTONAME:fontconfig-utils = "1"
58
59inherit autotools pkgconfig relative_symlinks gettext
60
61FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
62
63# comma separated list of additional directories
64# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
65FONTCONFIG_FONT_DIRS ?= "no"
66
67EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
68
69BBCLASSEXTEND = "native nativesdk"