summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/cairo/cairo_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/cairo/cairo_1.16.0.bb')
-rw-r--r--meta/recipes-graphics/cairo/cairo_1.16.0.bb98
1 files changed, 0 insertions, 98 deletions
diff --git a/meta/recipes-graphics/cairo/cairo_1.16.0.bb b/meta/recipes-graphics/cairo/cairo_1.16.0.bb
deleted file mode 100644
index 68f993d7ca..0000000000
--- a/meta/recipes-graphics/cairo/cairo_1.16.0.bb
+++ /dev/null
@@ -1,98 +0,0 @@
1SUMMARY = "The Cairo 2D vector graphics library"
2DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \
3vector-based rendering for multiple target backends. Paths consist \
4of line segments and cubic splines and can be rendered at any width \
5with various join and cap styles. All colors may be specified with \
6optional translucence (opacity/alpha) and combined using the \
7extended Porter/Duff compositing algebra as found in the X Render \
8Extension."
9HOMEPAGE = "http://cairographics.org"
10BUGTRACKER = "http://bugs.freedesktop.org"
11SECTION = "libs"
12
13LICENSE = "(MPL-1.1 | LGPLv2.1) & GPLv3+"
14LICENSE_${PN} = "MPL-1.1 | LGPLv2.1"
15LICENSE_${PN}-dev = "MPL-1.1 | LGPLv2.1"
16LICENSE_${PN}-doc = "MPL-1.1 | LGPLv2.1"
17LICENSE_${PN}-gobject = "MPL-1.1 | LGPLv2.1"
18LICENSE_${PN}-script-interpreter = "MPL-1.1 | LGPLv2.1"
19LICENSE_${PN}-perf-utils = "GPLv3+"
20
21LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77"
22
23DEPENDS = "fontconfig glib-2.0 libpng pixman zlib"
24
25SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \
26 file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \
27 file://CVE-2018-19876.patch \
28 file://CVE-2019-6461.patch \
29 file://CVE-2019-6462.patch \
30 "
31
32SRC_URI[md5sum] = "f19e0353828269c22bd72e271243a552"
33SRC_URI[sha256sum] = "5e7b29b3f113ef870d1e3ecf8adf21f923396401604bda16d44be45e66052331"
34
35inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script
36
37MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace"
38
39X11DEPENDS = "virtual/libx11 libsm libxrender libxext"
40
41PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \
42 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)} \
44 trace"
45PACKAGECONFIG_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}"
46PACKAGECONFIG_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}"
47
48PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}"
49PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb"
50PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb"
51PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind"
52PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl"
53PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2"
54PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl"
55PACKAGECONFIG[trace] = "--enable-trace,--disable-trace"
56
57EXTRA_OECONF += " \
58 ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \
59 --enable-tee \
60"
61
62# We don't depend on binutils so we need to disable this
63export ac_cv_lib_bfd_bfd_openr="no"
64# Ensure we don't depend on LZO
65export ac_cv_lib_lzo2_lzo2a_decompress="no"
66
67do_install_append () {
68 rm -rf ${D}${bindir}/cairo-sphinx
69 rm -rf ${D}${libdir}/cairo/cairo-fdr*
70 rm -rf ${D}${libdir}/cairo/cairo-sphinx*
71 rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr*
72 rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx*
73 [ ! -d ${D}${bindir} ] ||
74 rmdir -p --ignore-fail-on-non-empty ${D}${bindir}
75 [ ! -d ${D}${libdir}/cairo ] ||
76 rmdir -p --ignore-fail-on-non-empty ${D}${libdir}/cairo
77}
78
79PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
80
81SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library"
82DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API."
83
84SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter"
85DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \
86CairoScript. CairoScript is used by tracing utilities to enable the ability \
87to replay rendering."
88
89DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities"
90
91FILES_${PN} = "${libdir}/libcairo.so.*"
92FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*"
93FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*"
94FILES_${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so"
95
96BBCLASSEXTEND = "native nativesdk"
97
98UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+).tar.xz"