summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/libsecret/libsecret_0.20.0.bb')
-rw-r--r--meta/recipes-gnome/libsecret/libsecret_0.20.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb b/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
new file mode 100644
index 0000000000..aa3dfab581
--- /dev/null
+++ b/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets"
2DESCRIPTION = "A GObject-based library for accessing the Secret Service API of \
3the freedesktop.org project, a cross-desktop effort to access passwords, \
4tokens and other types of secrets. libsecret provides a convenient wrapper \
5for these methods so consumers do not have to call the low-level DBus methods."
6LICENSE = "LGPLv2.1"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/libsecret/issues"
8LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
9
10inherit gnomebase gtk-doc vala gobject-introspection manpages
11
12DEPENDS += "glib-2.0 libgcrypt gettext-native"
13
14PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
15
16SRC_URI += " file://0001-secret-file-collection-Rename-internal-functions-to-.patch"
17SRC_URI[archive.md5sum] = "335750caeed47f50496b3b0e6a1875ff"
18SRC_URI[archive.sha256sum] = "f1187370b453106af878e30c284a121ba0c513da8bb4170b329d66e250bdae43"
19
20# http://errors.yoctoproject.org/Errors/Details/20228/
21ARM_INSTRUCTION_SET_armv4 = "arm"
22ARM_INSTRUCTION_SET_armv5 = "arm"
23ARM_INSTRUCTION_SET_armv6 = "arm"
24
25# vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes
26do_configure_prepend() {
27 rm -f ${S}/build/m4/vapigen.m4
28}