summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/librsvg/librsvg_2.57.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/librsvg/librsvg_2.57.1.bb')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.57.1.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.57.1.bb b/meta/recipes-gnome/librsvg/librsvg_2.57.1.bb
new file mode 100644
index 0000000000..4b52d4062b
--- /dev/null
+++ b/meta/recipes-gnome/librsvg/librsvg_2.57.1.bb
@@ -0,0 +1,79 @@
1SUMMARY = "Library for rendering SVG files"
2DESCRIPTION = "A small library to render Scalable Vector Graphics (SVG), \
3associated with the GNOME Project. It renders SVG files to Cairo surfaces. \
4Cairo is the 2D, antialiased drawing library that GNOME uses to draw things to \
5the screen or to generate output for printing."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/librsvg"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/librsvg/issues"
8
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
11 "
12
13SECTION = "x11/utils"
14DEPENDS = "cairo gdk-pixbuf glib-2.0 libxml2 pango python3-docutils-native"
15BBCLASSEXTEND = "native nativesdk"
16
17GNOMEBASEBUILDCLASS = "autotools"
18inherit cargo_common gnomebase pixbufcache gobject-introspection rust vala gi-docgen cargo-update-recipe-crates
19
20require ${BPN}-crates.inc
21
22SRC_URI += " \
23 file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \
24 "
25
26SRC_URI[archive.sha256sum] = "074671a3ed6fbcd67cae2a40e539107f4f097ca8a4ab1a894c05e2524ff340ef"
27
28UPSTREAM_CHECK_REGEX = "librsvg-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
29
30# librsvg is still autotools-based, but is calling cargo from its automake-driven makefiles
31# so we cannot use cargo class directly, but still need bits and pieces from it
32# for cargo to be happy
33BASEDEPENDS:append = " cargo-native"
34
35export RUST_BACKTRACE = "full"
36export RUSTFLAGS
37
38export RUST_TARGET = "${RUST_HOST_SYS}"
39
40RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
41RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
42RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
43
44do_configure[postfuncs] += "cargo_common_do_configure"
45
46inherit rust-target-config
47
48# rust-cross writes the target linker binary into target json definition without any flags.
49# This breaks here because the linker isn't going to work without at least knowing where
50# the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class
51# which supplies the needed flags.
52do_compile:prepend() {
53 sed -ie 's,"linker": ".*","linker": "${RUST_TARGET_CC}",g' ${RUST_TARGETS_DIR}/${RUST_HOST_SYS}.json
54}
55
56CVE_STATUS[CVE-2018-1000041] = "not-applicable-platform: Issue only applies on Windows"
57
58CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
59
60PACKAGECONFIG ??= "gdkpixbuf"
61PACKAGECONFIG:append:class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vala', '', d)}"
62# The gdk-pixbuf loader
63PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
64PACKAGECONFIG[vala] = "--enable-vala,--disable-vala"
65
66do_install:append() {
67 # Loadable modules don't need .a or .la on Linux
68 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
69}
70
71PACKAGES =+ "librsvg-gtk rsvg"
72FILES:rsvg = "${bindir}/rsvg* \
73 ${datadir}/pixmaps/svg-viewer.svg \
74 ${datadir}/themes"
75FILES:librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so \
76 ${datadir}/thumbnailers/librsvg.thumbnailer"
77RRECOMMENDS:librsvg-gtk = "gdk-pixbuf-bin"
78
79PIXBUF_PACKAGES = "librsvg-gtk"