summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/librsvg/librsvg_2.52.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/librsvg/librsvg_2.52.4.bb')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.52.4.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.52.4.bb b/meta/recipes-gnome/librsvg/librsvg_2.52.4.bb
new file mode 100644
index 0000000000..bbaaefcd23
--- /dev/null
+++ b/meta/recipes-gnome/librsvg/librsvg_2.52.4.bb
@@ -0,0 +1,80 @@
1SUMMARY = "Library for rendering SVG files"
2DESCRIPTION = "A small library to render Scalable Vector Graphics (SVG), \
3associated with the GNOME Project. It renders SVG files to Cairo surfaces. \
4Cairo is the 2D, antialiased drawing library that GNOME uses to draw things to \
5the screen or to generate output for printing."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/librsvg"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/librsvg/issues"
8
9LICENSE = "LGPLv2.1+"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
11 "
12
13SECTION = "x11/utils"
14DEPENDS = "cairo gdk-pixbuf glib-2.0 libcroco libxml2 pango"
15BBCLASSEXTEND = "native"
16
17inherit gnomebase gtk-doc pixbufcache upstream-version-is-even gobject-introspection rust
18
19SRC_URI += "file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \
20 file://0001-system-deps-src-lib.rs-do-not-probe-into-harcoded-li.patch \
21 file://0001-vendor-system-deps-sort-dependencies-before-using-th.patch \
22 file://0005-Add-base-definitions-for-riscv64-musl-libc-0.2.93.patch \
23 file://0006-FIXUP-linux-musl-mod.rs-add-riscv64-to-b64-set-libc-.patch \
24 file://0007-FIXUP-Correct-definitions-to-match-musl-libc-0.2.93.patch \
25 file://0001-Update-checksums-for-modified-files-for-libc.patch \
26 "
27
28SRC_URI[archive.sha256sum] = "660ec8836a3a91587bc9384920132d4c38d1d1718c67fe160c5213fe4dec2928"
29
30# librsvg is still autotools-based, but is calling cargo from its automake-driven makefiles
31# so we cannot use cargo class directly, but still need bits and pieces from it
32# for cargo to be happy
33BASEDEPENDS:append = " cargo-native"
34
35export RUST_BACKTRACE = "full"
36export RUSTFLAGS
37export RUST_TARGET_PATH
38
39export RUST_TARGET = "${HOST_SYS}"
40
41RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
42RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
43RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
44RUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64"
45
46# rust-cross writes the target linker binary into target json definition without any flags.
47# This breaks here because the linker isn't going to work without at least knowing where
48# the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class
49# which supplies the needed flags.
50do_compile:prepend() {
51 cp ${STAGING_LIBDIR_NATIVE}/rustlib/${HOST_SYS}.json ${WORKDIR}
52 cp ${STAGING_LIBDIR_NATIVE}/rustlib/${BUILD_SYS}.json ${WORKDIR}
53 sed -ie 's,"linker": ".*","linker": "${RUST_TARGET_CC}",g' ${WORKDIR}/${HOST_SYS}.json
54 RUST_TARGET_PATH="${WORKDIR}"
55 export RUST_TARGET_PATH
56}
57
58# Issue only on windows
59CVE_CHECK_WHITELIST += "CVE-2018-1000041"
60
61CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
62
63PACKAGECONFIG ??= "gdkpixbuf"
64# The gdk-pixbuf loader
65PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
66
67do_install:append() {
68 # Loadable modules don't need .a or .la on Linux
69 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
70}
71
72PACKAGES =+ "librsvg-gtk rsvg"
73FILES:rsvg = "${bindir}/rsvg* \
74 ${datadir}/pixmaps/svg-viewer.svg \
75 ${datadir}/themes"
76FILES:librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so \
77 ${datadir}/thumbnailers/librsvg.thumbnailer"
78RRECOMMENDS:librsvg-gtk = "gdk-pixbuf-bin"
79
80PIXBUF_PACKAGES = "librsvg-gtk"