summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/libnotify/libnotify_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/libnotify/libnotify_0.8.2.bb')
-rw-r--r--meta/recipes-gnome/libnotify/libnotify_0.8.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-gnome/libnotify/libnotify_0.8.2.bb b/meta/recipes-gnome/libnotify/libnotify_0.8.2.bb
new file mode 100644
index 0000000000..bbfc217df1
--- /dev/null
+++ b/meta/recipes-gnome/libnotify/libnotify_0.8.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Library for sending desktop notifications to a notification daemon"
2DESCRIPTION = "It sends desktop notifications to a notification daemon, as defined \
3in the Desktop Notifications spec. These notifications can be used to inform \
4the user about an event or display some form of information without getting \
5in the user's way."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/libnotify"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/libnotify/issues"
8SECTION = "libs"
9LICENSE = "LGPL-2.1-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "dbus glib-2.0 gdk-pixbuf"
13
14PACKAGECONFIG ?= ""
15PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gtk+3"
16
17GNOMEBASEBUILDCLASS = "meson"
18GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20inherit gnomebase gi-docgen features_check gobject-introspection
21# depends on gtk+3 if tests are enabled
22ANY_OF_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'tests', '${GTK3DISTROFEATURES}', '', d)}"
23
24SRC_URI[archive.sha256sum] = "c5f4ed3d1f86e5b118c76415aacb861873ed3e6f0c6b3181b828cf584fc5c616"
25
26EXTRA_OEMESON = "-Dman=false"
27
28# there were times, we had two versions of libnotify (oe-core libnotify:0.6.x /
29# meta-gnome libnotify3: 0.7.x)
30PROVIDES += "libnotify3"
31RPROVIDES:${PN} += "libnotify3"
32RCONFLICTS:${PN} += "libnotify3"
33RREPLACES:${PN} += "libnotify3"
34
35# -7381 is specific to the NodeJS bindings
36CVE_CHECK_IGNORE += "CVE-2013-7381"