summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/json-glib/json-glib_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/json-glib/json-glib_1.8.0.bb')
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.8.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.8.0.bb b/meta/recipes-gnome/json-glib/json-glib_1.8.0.bb
new file mode 100644
index 0000000000..2094ebe3e7
--- /dev/null
+++ b/meta/recipes-gnome/json-glib/json-glib_1.8.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
8
9LICENSE = "LGPL-2.1-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0 glib-2.0-native"
13
14inherit gnomebase lib_package gobject-introspection gi-docgen gettext ptest-gnome manpages upstream-version-is-even
15GIR_MESON_ENABLE_FLAG = 'enabled'
16GIR_MESON_DISABLE_FLAG = 'disabled'
17GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'
18GIDOCGEN_MESON_DISABLE_FLAG = 'disabled'
19
20SRC_URI += " file://run-ptest"
21SRC_URI[archive.sha256sum] = "97ef5eb92ca811039ad50a65f06633f1aae64792789307be7170795d8b319454"
22
23PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
24PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
25PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
26
27BBCLASSEXTEND = "native nativesdk"
28
29# Currently it's not possible to disable gettext in Meson, so we need to force
30# this back on.
31USE_NLS:class-native = "yes"