summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/json-glib/json-glib_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/json-glib/json-glib_1.6.2.bb')
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.6.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.6.2.bb b/meta/recipes-gnome/json-glib/json-glib_1.6.2.bb
new file mode 100644
index 0000000000..fdf3b245e8
--- /dev/null
+++ b/meta/recipes-gnome/json-glib/json-glib_1.6.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
8
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0"
13
14GNOMEBASEBUILDCLASS = "meson"
15inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages upstream-version-is-even
16GIR_MESON_ENABLE_FLAG = 'enabled'
17GIR_MESON_DISABLE_FLAG = 'disabled'
18GTKDOC_MESON_OPTION = "gtk_doc"
19GTKDOC_MESON_ENABLE_FLAG = 'enabled'
20GTKDOC_MESON_DISABLE_FLAG = 'disabled'
21
22SRC_URI += " file://run-ptest"
23SRC_URI[archive.sha256sum] = "a33d66c6d038bda46b910c6c6d59c4e15db014e363dc997a0414c2e07d134f24"
24
25PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
26PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
27PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
28
29BBCLASSEXTEND = "native nativesdk"
30
31# Currently it's not possible to disable gettext in Meson, so we need to force
32# this back on.
33USE_NLS_class-native = "yes"