summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/json-glib/json-glib_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/json-glib/json-glib_1.6.0.bb')
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.6.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.6.0.bb b/meta/recipes-gnome/json-glib/json-glib_1.6.0.bb
new file mode 100644
index 0000000000..3cb637f220
--- /dev/null
+++ b/meta/recipes-gnome/json-glib/json-glib_1.6.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
8
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0"
13
14GNOMEBASEBUILDCLASS = "meson"
15inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages upstream-version-is-even
16GIR_MESON_ENABLE_FLAG = 'enabled'
17GIR_MESON_DISABLE_FLAG = 'disabled'
18GTKDOC_MESON_OPTION = "gtk_doc"
19GTKDOC_MESON_ENABLE_FLAG = 'enabled'
20GTKDOC_MESON_DISABLE_FLAG = 'disabled'
21
22SRC_URI += " file://run-ptest"
23SRC_URI[archive.sha256sum] = "0d7c67602c4161ea7070fab6c5823afd9bd7f7bc955f652a50d3753b08494e73"
24
25PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
26
27do_install_append() {
28 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
29 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
30 fi
31}
32
33BBCLASSEXTEND = "native nativesdk"
34
35# Currently it's not possible to disable gettext in Meson, so we need to force
36# this back on.
37USE_NLS_class-native = "yes"