summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/json-glib/json-glib_1.4.2.bb')
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.4.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb b/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
new file mode 100644
index 0000000000..fad0a2df36
--- /dev/null
+++ b/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "http://live.gnome.org/JsonGlib"
7
8LICENSE = "LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11DEPENDS = "glib-2.0"
12
13SRC_URI[archive.md5sum] = "35107e23a7bbbc70f31c34f7b9adf1c3"
14SRC_URI[archive.sha256sum] = "2d7709a44749c7318599a6829322e081915bdc73f5be5045882ed120bb686dc8"
15
16GNOMEBASEBUILDCLASS = "meson"
17inherit gnomebase lib_package gobject-introspection gtk-doc manpages gettext
18
19GTKDOC_ENABLE_FLAG = "-Denable-gtk-doc=true"
20GTKDOC_DISABLE_FLAG = "-Denable-gtk-doc=false"
21
22GI_ENABLE_FLAG = "-Ddisable_introspection=false"
23GI_DISABLE_FLAG = "-Ddisable_introspection=true"
24
25EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \
26 '${GTKDOC_DISABLE_FLAG}', d)} "
27EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
28 '${GI_DISABLE_FLAG}', d)} "
29
30PACKAGECONFIG[manpages] = "-Denable-man=true, -Denable-man=false, libxslt-native xmlto-native"
31
32do_install_append() {
33 # FIXME: these need to be provided via ptest
34 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
35}
36
37BBCLASSEXTEND = "native nativesdk"