summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gnome-themes-standard_3.22.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gnome-themes-standard_3.22.2.bb')
-rw-r--r--meta/recipes-gnome/gnome/gnome-themes-standard_3.22.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-themes-standard_3.22.2.bb b/meta/recipes-gnome/gnome/gnome-themes-standard_3.22.2.bb
new file mode 100644
index 0000000000..2b3cc975c2
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gnome-themes-standard_3.22.2.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9inherit autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even distro_features_check
10
11ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
12
13DEPENDS += "intltool-native gtk+"
14
15MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
17 "
18
19SRC_URI[md5sum] = "84624dbcecab7add32672abae030314d"
20SRC_URI[sha256sum] = "b34516cd59b873c187c1897c25bac3b9ce2d30a472f1fd7ae9d7105d93e17da5"
21
22EXTRA_OECONF = "--disable-gtk3-engine"
23
24do_install_append() {
25 # Only building Adwaita, remove highcontrast files
26 rm -rf ${D}${prefix}/share/themes/HighContrast \
27 ${D}${prefix}/share/icons
28}
29
30# There could be gnome-theme-highcontrast as well but that requires
31# gtk+3 and includes lots of icons (is also broken with B != S).
32PACKAGES += "gnome-theme-adwaita \
33 gnome-theme-adwaita-dbg \
34 gnome-theme-adwaita-devĀ \
35 gnome-theme-adwaita-dark \
36 "
37
38FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
39 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
40FILES_gnome-theme-adwaita-dev = "${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la"
41FILES_gnome-theme-adwaita-dbg = "${libdir}/gtk-2.0/2.10.0/engines/.debug/libadwaita.so"
42
43FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
44RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita"
45