summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf_3.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf_3.2.6.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.6.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.6.bb b/meta/recipes-gnome/gnome/gconf_3.2.6.bb
index ade93644ec..dd760b9c63 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.6.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.6.bb
@@ -28,12 +28,12 @@ EXTRA_OECONF = "--enable-shared --disable-static \
28 28
29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}" 29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
30# We really don't want Polkit for native 30# We really don't want Polkit for native
31PACKAGECONFIG_class-native = "" 31PACKAGECONFIG:class-native = ""
32 32
33PACKAGECONFIG[polkit] = "--enable-defaults-service,--disable-defaults-service,polkit" 33PACKAGECONFIG[polkit] = "--enable-defaults-service,--disable-defaults-service,polkit"
34PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum" 34PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum"
35 35
36do_install_append() { 36do_install:append() {
37 # this directory need to be created to avoid an Error 256 at gdm launch 37 # this directory need to be created to avoid an Error 256 at gdm launch
38 install -d ${D}${sysconfdir}/gconf/gconf.xml.system 38 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
39 39
@@ -42,19 +42,19 @@ do_install_append() {
42 rm -f ${D}${libdir}/gio/*/*.*a 42 rm -f ${D}${libdir}/gio/*/*.*a
43} 43}
44 44
45do_install_append_class-native() { 45do_install:append:class-native() {
46 create_wrapper ${D}/${bindir}/gconftool-2 \ 46 create_wrapper ${D}/${bindir}/gconftool-2 \
47 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2 47 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
48} 48}
49 49
50FILES_${PN} += "${libdir}/GConf/* \ 50FILES:${PN} += "${libdir}/GConf/* \
51 ${libdir}/gio/*/*.so \ 51 ${libdir}/gio/*/*.so \
52 ${datadir}/polkit* \ 52 ${datadir}/polkit* \
53 ${datadir}/dbus-1/services/*.service \ 53 ${datadir}/dbus-1/services/*.service \
54 ${datadir}/dbus-1/system-services/*.service \ 54 ${datadir}/dbus-1/system-services/*.service \
55 " 55 "
56RDEPENDS_${PN} = "python3-xml" 56RDEPENDS:${PN} = "python3-xml"
57 57
58FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd" 58FILES:${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
59 59
60BBCLASSEXTEND = "native" 60BBCLASSEXTEND = "native"