summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf_3.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf_3.2.6.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.6.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.6.bb b/meta/recipes-gnome/gnome/gconf_3.2.6.bb
new file mode 100644
index 0000000000..17fdafa969
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gconf_3.2.6.bb
@@ -0,0 +1,60 @@
1SUMMARY = "GNOME configuration system"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native gobject-introspection-stub"
7DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
8
9
10inherit gnomebase gtk-doc gettext
11
12SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
13 file://remove_plus_from_invalid_characters_list.patch \
14 file://unable-connect-dbus.patch \
15"
16
17SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c"
18SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c"
19
20S = "${WORKDIR}/GConf-${PV}"
21
22EXTRA_OECONF = "--enable-shared --disable-static --enable-debug=yes \
23 --disable-introspection --disable-orbit --with-openldap=no --disable-gtk"
24
25# Disable PolicyKit by default
26PACKAGECONFIG ??= ""
27# We really don't want PolicyKit for native or uclibc
28PACKAGECONFIG_class-native = ""
29PACKAGECONFIG_libc-uclibc = ""
30
31PACKAGECONFIG[policykit] = "--enable-defaults-service,--disable-defaults-service,polkit"
32
33do_install_append() {
34 # this directory need to be created to avoid an Error 256 at gdm launch
35 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
36
37 # this stuff is unusable
38 rm -f ${D}${libdir}/GConf/*/*.*a
39 rm -f ${D}${libdir}/gio/*/*.*a
40}
41
42do_install_append_class-native() {
43 create_wrapper ${D}/${bindir}/gconftool-2 \
44 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
45}
46
47# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
48RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
49RDEPENDS_${PN}_class-native = ""
50
51FILES_${PN} += "${libdir}/GConf/* \
52 ${libdir}/gio/*/*.so \
53 ${datadir}/polkit* \
54 ${datadir}/dbus-1/services/*.service \
55 ${datadir}/dbus-1/system-services/*.service \
56 "
57FILES_${PN}-dbg += "${libdir}/*/*/.debug"
58FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
59
60BBCLASSEXTEND = "native"