summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf_3.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf_3.2.3.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
deleted file mode 100644
index ef21624de1..0000000000
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1DESCRIPTION = "GNOME configuration system"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6POLKIT = "polkit"
7POLKIT_libc-uclibc = ""
8
9DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
10DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
11
12PR = "r13"
13
14inherit gnomebase gtk-doc
15
16SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.bz2;name=archive \
17 file://backenddir.patch"
18
19SRC_URI[archive.md5sum] = "f80329173cd9d134ad07e36002dd2a15"
20SRC_URI[archive.sha256sum] = "52008a82a847527877d9e1e549a351c86cc53cada4733b8a70a1123925d6aff4"
21
22S = "${WORKDIR}/GConf-${PV}"
23
24POLKIT_OECONF = "--enable-defaults-service"
25POLKIT_OECONF_class-native = "--disable-defaults-service"
26POLKIT_OECONF_libc-uclibc = "--disable-default-service"
27
28EXTRA_OECONF = "--enable-shared --disable-static --enable-debug=yes \
29 --disable-introspection --disable-orbit --with-openldap=no ${POLKIT_OECONF} --disable-gtk"
30
31do_install_append() {
32 # this directory need to be created to avoid an Error 256 at gdm launch
33 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
34
35 # this stuff is unusable
36 rm -f ${D}${libdir}/GConf/*/*.*a
37 rm -f ${D}${libdir}/gio/*/*.*a
38}
39
40do_install_append_class-native() {
41 create_wrapper ${D}/${bindir}/gconftool-2 \
42 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
43}
44
45# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
46RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
47RDEPENDS_${PN}_class-native = ""
48
49FILES_${PN} += "${libdir}/GConf/* \
50 ${libdir}/gio/*/*.so \
51 ${datadir}/polkit* \
52 ${datadir}/dbus-1/services/*.service \
53 ${datadir}/dbus-1/system-services/*.service \
54 "
55FILES_${PN}-dbg += "${libdir}/*/*/.debug"
56FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
57
58BBCLASSEXTEND = "native"