summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/adwaita-icon-theme_3.38.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/adwaita-icon-theme_3.38.0.bb')
-rw-r--r--meta/recipes-gnome/gnome/adwaita-icon-theme_3.38.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/adwaita-icon-theme_3.38.0.bb b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.38.0.bb
new file mode 100644
index 0000000000..ff557978dc
--- /dev/null
+++ b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.38.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "GTK+ icon theme"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
3BUGTRACKER = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme/issues"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-3.0 | CC-BY-SA-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c \
8 file://COPYING_CCBYSA3;md5=96143d33de3a79321b1006c4e8ed07e7 \
9 file://COPYING_LGPL;md5=e6a600fd5e1d9cbde2d983680233ad02"
10
11inherit allarch autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even
12
13MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
14SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
15 file://0001-Don-t-use-AC_CANONICAL_HOST.patch \
16 file://0001-Run-installation-commands-as-shell-jobs.patch \
17 "
18
19SRC_URI[sha256sum] = "6683a1aaf2430ccd9ea638dd4bfe1002bc92b412050c3dba20e480f979faaf97"
20
21DEPENDS += "librsvg-native"
22
23PACKAGES = "${PN}-cursors ${PN}-symbolic-hires ${PN}-symbolic ${PN}-hires ${PN}"
24
25RREPLACES_${PN} = "gnome-icon-theme"
26RCONFLICTS_${PN} = "gnome-icon-theme"
27RPROVIDES_${PN} = "gnome-icon-theme"
28
29FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/"
30FILES_${PN}-symbolic-hires = "${prefix}/share/icons/Adwaita/96x96/*/*.symbolic.png \
31 ${prefix}/share/icons/Adwaita/64x64/*/*.symbolic.png \
32 ${prefix}/share/icons/Adwaita/48x48/*/*.symbolic.png \
33 ${prefix}/share/icons/Adwaita/32x32/*/*.symbolic.png"
34FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/16x16/*/*.symbolic.png \
35 ${prefix}/share/icons/Adwaita/24x24/*/*.symbolic.png \
36 ${prefix}/share/icons/Adwaita/scalable/*/*-symbolic*.svg"
37FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/ \
38 ${prefix}/share/icons/Adwaita/512x512/"
39FILES_${PN} = "${prefix}/share/icons/Adwaita/ \
40 ${prefix}/share/pkgconfig/adwaita-icon-theme.pc"
41
42BBCLASSEXTEND = "native nativesdk"