summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/adwaita-icon-theme_3.28.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/adwaita-icon-theme_3.28.0.bb')
-rw-r--r--meta/recipes-gnome/gnome/adwaita-icon-theme_3.28.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/adwaita-icon-theme_3.28.0.bb b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.28.0.bb
new file mode 100644
index 0000000000..40dd35ba30
--- /dev/null
+++ b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.28.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "GTK+ icon theme"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/adwaita-icon-theme/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-3.0 | CC-BY-SA-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c"
8
9inherit allarch autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even
10
11
12MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
13SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
14 file://0001-Don-t-use-AC_CANONICAL_HOST.patch \
15 file://0001-Run-installation-commands-as-shell-jobs.patch \
16 "
17
18SRC_URI[md5sum] = "b25b2d82cbebf2cc9cd469457b604f2c"
19SRC_URI[sha256sum] = "7aae8c1dffd6772fd1a21a3d365a0ea28b7c3988bdbbeafbf8742cda68242150"
20
21do_install_append() {
22 # Build uses gtk-encode-symbolic-svg to create png versions:
23 # no need to store the svgs anymore.
24 rm -f ${D}${prefix}/share/icons/Adwaita/scalable/*/*-symbolic.svg \
25 ${D}${prefix}/share/icons/Adwaita/scalable/*/*-symbolic-rtl.svg
26}
27
28PACKAGES = "${PN}-cursors ${PN}-symbolic-hires ${PN}-symbolic ${PN}-hires ${PN}"
29
30RREPLACES_${PN} = "gnome-icon-theme"
31RCONFLICTS_${PN} = "gnome-icon-theme"
32RPROVIDES_${PN} = "gnome-icon-theme"
33
34FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/"
35FILES_${PN}-symbolic-hires = "${prefix}/share/icons/Adwaita/96x96/*/*.symbolic.png \
36 ${prefix}/share/icons/Adwaita/64x64/*/*.symbolic.png \
37 ${prefix}/share/icons/Adwaita/48x48/*/*.symbolic.png \
38 ${prefix}/share/icons/Adwaita/32x32/*/*.symbolic.png"
39FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/16x16/*/*.symbolic.png \
40 ${prefix}/share/icons/Adwaita/24x24/*/*.symbolic.png"
41FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/ \
42 ${prefix}/share/icons/Adwaita/512x512/"
43FILES_${PN} = "${prefix}/share/icons/Adwaita/ \
44 ${prefix}/share/pkgconfig/adwaita-icon-theme.pc"