summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gcr/gcr_3.28.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gcr/gcr_3.28.0.bb')
-rw-r--r--meta/recipes-gnome/gcr/gcr_3.28.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gcr/gcr_3.28.0.bb b/meta/recipes-gnome/gcr/gcr_3.28.0.bb
new file mode 100644
index 0000000000..6777ad2277
--- /dev/null
+++ b/meta/recipes-gnome/gcr/gcr_3.28.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "A library for bits of crypto UI and parsing etc"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
7
8DEPENDS = "intltool-native gtk+3 p11-kit glib-2.0 libgcrypt \
9 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
10
11inherit gnomebase gtk-icon-cache gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
12# depends on gtk+3, but also x11 through gtk+-x11
13REQUIRED_DISTRO_FEATURES = "x11"
14
15SRC_URI[archive.md5sum] = "5321319307dad34dca2fd52e7c9c01ab"
16SRC_URI[archive.sha256sum] = "15e175d1da7ec486d59749ba34906241c442898118ce224a7b70bf2e849faf0b"
17
18FILES_${PN} += " \
19 ${datadir}/dbus-1 \
20 ${datadir}/gcr-3 \
21"
22
23# http://errors.yoctoproject.org/Errors/Details/20229/
24ARM_INSTRUCTION_SET = "arm"
25
26# These files may be out of date or missing our fixes
27# libgcrypt.m4 in particular is calling into libgcrypt-config
28do_configure_prepend() {
29 rm -f ${S}/build/m4/*
30}