summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/epiphany/epiphany_3.18.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/epiphany/epiphany_3.18.4.bb')
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_3.18.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-gnome/epiphany/epiphany_3.18.4.bb b/meta/recipes-gnome/epiphany/epiphany_3.18.4.bb
new file mode 100644
index 0000000000..12d3b07b72
--- /dev/null
+++ b/meta/recipes-gnome/epiphany/epiphany_3.18.4.bb
@@ -0,0 +1,26 @@
1SUMMARY = "WebKit based web browser for GNOME"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes ca-certificates avahi libnotify gcr libwnck3 \
6 gsettings-desktop-schemas gnome-desktop3 libxml2-native"
7
8inherit gnomebase gsettings distro_features_check upstream-version-is-even
9# libwnck3 is x11 only
10REQUIRED_DISTRO_FEATURES = "x11"
11
12SRC_URI += "file://0001-yelp.m4-drop-the-check-for-itstool.patch"
13SRC_URI[archive.md5sum] = "172b78256100e8d3c629764abd0e1495"
14SRC_URI[archive.sha256sum] = "be699d484371111abae754e669187215df73e21533f461e513b79537d7a1c1c1"
15
16EXTRA_OECONF += " --disable-nss --with-distributor-name=${DISTRO}"
17
18do_configure_prepend() {
19 touch ${S}/gnome-doc-utils.make
20 sed -i -e s:help::g ${S}/Makefile.am
21}
22
23FILES_${PN} += "${datadir}/appdata ${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers"
24RDEPENDS_${PN} = "iso-codes adwaita-icon-theme"
25RRECOMMENDS_${PN} = "ca-certificates"
26