summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/zip/zip_3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/zip/zip_3.0.bb')
-rw-r--r--meta/recipes-extended/zip/zip_3.0.bb40
1 files changed, 32 insertions, 8 deletions
diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
index 383da4b89e..087423a045 100644
--- a/meta/recipes-extended/zip/zip_3.0.bb
+++ b/meta/recipes-extended/zip/zip_3.0.bb
@@ -1,18 +1,42 @@
1require zip.inc 1SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
2 4
3PR="r2" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
7
8PR = "r2"
4 9
5# zip-2.32 still uses directory name of zip-2.30
6S = "${WORKDIR}/zip30" 10S = "${WORKDIR}/zip30"
7 11
12SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
13 file://fix-security-format.patch"
14
8SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37" 15SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
9SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369" 16SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
10 17
11# exclude version 2.3.2 which triggers a false positive
12UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
13
14# zip.inc sets CFLAGS, but what Makefile actually uses is 18# zip.inc sets CFLAGS, but what Makefile actually uses is
15# CFLAGS_NOOPT. It will also force -O3 optimization, overriding 19# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
16# whatever we set. 20# whatever we set.
17# 21EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
18EXTRA_OEMAKE_append = " 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}'" 22 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
23 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
24 'INSTALL=install' 'INSTALL_D=install -d' \
25 'BINFLAGS=0755'"
26
27do_compile() {
28 oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
29 sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
30 oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
31}
32
33do_install() {
34 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
35 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
36 install
37}
38
39BBCLASSEXTEND = "native"
40
41# exclude version 2.3.2 which triggers a false positive
42UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"