summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb')
-rw-r--r--meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb29
1 files changed, 18 insertions, 11 deletions
diff --git a/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb b/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
index 4f0f9531a1..72eb1ae067 100644
--- a/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
+++ b/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
@@ -1,14 +1,13 @@
1SUMMARY = "Socket-based service activation daemon" 1SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd" 2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
3DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things."
3 4
4# xinetd is a BSD-like license 5LICENSE = "xinetd"
5# Apple and Gentoo say BSD here.
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f" 6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
8 7
9UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" 8UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
10 9
11SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \ 10SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https;branch=master \
12 file://xinetd.init \ 11 file://xinetd.init \
13 file://xinetd.default \ 12 file://xinetd.default \
14 file://xinetd.service \ 13 file://xinetd.service \
@@ -18,9 +17,12 @@ SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
20# https://github.com/xinetd-org/xinetd/pull/10 is merged into this git tree revision
21CVE_STATUS[CVE-2013-4342] = "fixed-version: Fixed directly in git tree revision"
22
21inherit autotools update-rc.d systemd pkgconfig 23inherit autotools update-rc.d systemd pkgconfig
22 24
23SYSTEMD_SERVICE_${PN} = "xinetd.service" 25SYSTEMD_SERVICE:${PN} = "xinetd.service"
24 26
25INITSCRIPT_NAME = "xinetd" 27INITSCRIPT_NAME = "xinetd"
26INITSCRIPT_PARAMS = "defaults" 28INITSCRIPT_PARAMS = "defaults"
@@ -28,20 +30,25 @@ INITSCRIPT_PARAMS = "defaults"
28PACKAGECONFIG ??= "tcp-wrappers" 30PACKAGECONFIG ??= "tcp-wrappers"
29PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers" 31PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
30 32
31CONFFILES_${PN} = "${sysconfdir}/xinetd.conf" 33CFLAGS += "-D_GNU_SOURCE"
34
35CONFFILES:${PN} = "${sysconfdir}/xinetd.conf"
32 36
33do_install_append() { 37do_install:append() {
34 install -d "${D}${sysconfdir}/init.d" 38 install -d "${D}${sysconfdir}/init.d"
35 install -d "${D}${sysconfdir}/default" 39 install -d "${D}${sysconfdir}/default"
36 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd" 40 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
37 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd" 41 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
38 42
39 # Install systemd unit files 43 # Install systemd unit files
40 install -d ${D}${systemd_unitdir}/system 44 install -d ${D}${systemd_system_unitdir}
41 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system 45 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_system_unitdir}
42 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ 46 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
43 -e 's,@SBINDIR@,${sbindir},g' \ 47 -e 's,@SBINDIR@,${sbindir},g' \
44 ${D}${systemd_unitdir}/system/xinetd.service 48 ${D}${systemd_system_unitdir}/xinetd.service
45} 49}
46 50
47RDEPENDS_${PN} += "perl" 51# Script for converting inetd.conf files into xinetd.conf files
52PACKAGES =+ "${PN}-xconv"
53FILES:${PN}-xconv = "${bindir}/xconv.pl"
54RDEPENDS:${PN}-xconv += "perl"