summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2018i.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2018i.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2018i.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2018i.bb b/meta/recipes-extended/tzcode/tzcode-native_2018i.bb
new file mode 100644
index 0000000000..f056370b4a
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2018i.bb
@@ -0,0 +1,30 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c679c9d6b02bc2757b3eaf8f53c43fba"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata \
10 "
11
12UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
13
14SRC_URI[tzcode.md5sum] = "6a6d98be8fa2fa3485e25343e79188b4"
15SRC_URI[tzcode.sha256sum] = "aaacdb876ca6fb9d58e244b462cbc7578a496b1b10994381b4b32b9f2ded32dc"
16SRC_URI[tzdata.md5sum] = "b3f0a1a789480a036e58466cd0702477"
17SRC_URI[tzdata.sha256sum] = "82c45ef84ca3bc01d0a4a397ba8adeb8f7f199c6550740587c6ac5a7108c00d9"
18
19S = "${WORKDIR}"
20
21inherit native
22
23EXTRA_OEMAKE += "cc='${CC}'"
24
25do_install () {
26 install -d ${D}${bindir}/
27 install -m 755 zic ${D}${bindir}/
28 install -m 755 zdump ${D}${bindir}/
29 install -m 755 tzselect ${D}${bindir}/
30}