summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2018c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2018c.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2018c.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2018c.bb b/meta/recipes-extended/tzcode/tzcode-native_2018c.bb
new file mode 100644
index 0000000000..85e9b70ace
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2018c.bb
@@ -0,0 +1,30 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c679c9d6b02bc2757b3eaf8f53c43fba"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata \
10 "
11
12UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
13
14SRC_URI[tzcode.md5sum] = "e6e0d4b2ce3fa6906f303157bed2612e"
15SRC_URI[tzcode.sha256sum] = "31fa7fc0f94a6ff2d6bc878c0a35e8ab8b5aa0e8b01445a1d4a8f14777d0e665"
16SRC_URI[tzdata.md5sum] = "c412b1531adef1be7a645ab734f86acc"
17SRC_URI[tzdata.sha256sum] = "2825c3e4b7ef520f24d393bcc02942f9762ffd3e7fc9b23850789ed8f22933f6"
18
19S = "${WORKDIR}"
20
21inherit native
22
23EXTRA_OEMAKE += "cc='${CC}'"
24
25do_install () {
26 install -d ${D}${bindir}/
27 install -m 755 zic ${D}${bindir}/
28 install -m 755 zdump ${D}${bindir}/
29 install -m 755 tzselect ${D}${bindir}/
30}