summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texinfo/texinfo_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/texinfo/texinfo_5.2.bb')
-rw-r--r--meta/recipes-extended/texinfo/texinfo_5.2.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo_5.2.bb b/meta/recipes-extended/texinfo/texinfo_5.2.bb
index 7b5a11a874..cf9dcfd5de 100644
--- a/meta/recipes-extended/texinfo/texinfo_5.2.bb
+++ b/meta/recipes-extended/texinfo/texinfo_5.2.bb
@@ -9,6 +9,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9 9
10PROVIDES_append_class-native = " texinfo-replacement-native" 10PROVIDES_append_class-native = " texinfo-replacement-native"
11 11
12def compress_pkg(d):
13 if "compress_doc" in (d.getVar("INHERIT", True) or "").split():
14 compress = d.getVar("DOC_COMPRESS", True)
15 if compress == "gz":
16 return "gzip"
17 elif compress == "bz2":
18 return "bzip2"
19 elif compress == "xz":
20 return "xz"
21 return ""
22
23RDEPENDS_info += "${@compress_pkg(d)}"
24
12DEPENDS = "zlib ncurses texinfo-replacement-native" 25DEPENDS = "zlib ncurses texinfo-replacement-native"
13DEPENDS_class-native = "zlib-native ncurses-native" 26DEPENDS_class-native = "zlib-native ncurses-native"
14 27