summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tar/tar_1.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tar/tar_1.35.bb')
-rw-r--r--meta/recipes-extended/tar/tar_1.35.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-extended/tar/tar_1.35.bb b/meta/recipes-extended/tar/tar_1.35.bb
new file mode 100644
index 0000000000..4dbd418b60
--- /dev/null
+++ b/meta/recipes-extended/tar/tar_1.35.bb
@@ -0,0 +1,68 @@
1SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
6LICENSE = "GPL-3.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
8
9SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
10
11SRC_URI[sha256sum] = "7edb8886a3dc69420a1446e1e2d061922b642f1cf632d2cd0f9ee7e690775985"
12
13inherit autotools gettext texinfo
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
17
18PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
19PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
20
21EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
22
23CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
24
25# Let aclocal use the relative path for the m4 file rather than the
26# absolute since tar has a lot of m4 files, otherwise there might
27# be an "Argument list too long" error when it is built in a long/deep
28# directory.
29acpaths = "-I ./m4"
30
31do_install () {
32 autotools_do_install
33 ln -s tar ${D}${bindir}/gtar
34}
35
36do_install:append:class-target() {
37 if [ "${base_bindir}" != "${bindir}" ]; then
38 install -d ${D}${base_bindir}
39 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
40 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
41 rmdir ${D}${bindir}/
42 fi
43}
44
45PACKAGES =+ "${PN}-rmt"
46
47FILES:${PN}-rmt = "${sbindir}/rmt*"
48
49inherit update-alternatives
50
51ALTERNATIVE_PRIORITY = "100"
52
53ALTERNATIVE:${PN} = "tar"
54ALTERNATIVE:${PN}-rmt = "rmt"
55ALTERNATIVE:${PN}:class-nativesdk = ""
56ALTERNATIVE:${PN}-rmt:class-nativesdk = ""
57
58ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
59ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
60
61PROVIDES:append:class-native = " tar-replacement-native"
62NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
63
64BBCLASSEXTEND = "native nativesdk"
65
66# Avoid false positives from CVEs in node-tar package
67# For example CVE-2021-{32803,32804,37701,37712,37713}
68CVE_PRODUCT = "gnu:tar"