summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tar/tar_1.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tar/tar_1.34.bb')
-rw-r--r--meta/recipes-extended/tar/tar_1.34.bb63
1 files changed, 0 insertions, 63 deletions
diff --git a/meta/recipes-extended/tar/tar_1.34.bb b/meta/recipes-extended/tar/tar_1.34.bb
deleted file mode 100644
index af04919c41..0000000000
--- a/meta/recipes-extended/tar/tar_1.34.bb
+++ /dev/null
@@ -1,63 +0,0 @@
1SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
10
11SRC_URI[sha256sum] = "b44cc67f8a1f6b0250b7c860e952b37e8ed932a90bd9b1862a511079255646ff"
12
13inherit autotools gettext texinfo
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
17
18PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
19
20EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
21
22CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
23
24# Let aclocal use the relative path for the m4 file rather than the
25# absolute since tar has a lot of m4 files, otherwise there might
26# be an "Argument list too long" error when it is built in a long/deep
27# directory.
28acpaths = "-I ./m4"
29
30do_install () {
31 autotools_do_install
32 ln -s tar ${D}${bindir}/gtar
33}
34
35do_install_append_class-target() {
36 if [ "${base_bindir}" != "${bindir}" ]; then
37 install -d ${D}${base_bindir}
38 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
39 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
40 rmdir ${D}${bindir}/
41 fi
42}
43
44PACKAGES =+ "${PN}-rmt"
45
46FILES_${PN}-rmt = "${sbindir}/rmt*"
47
48inherit update-alternatives
49
50ALTERNATIVE_PRIORITY = "100"
51
52ALTERNATIVE_${PN} = "tar"
53ALTERNATIVE_${PN}-rmt = "rmt"
54ALTERNATIVE_${PN}_class-nativesdk = ""
55ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
56
57ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
58ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
59
60PROVIDES_append_class-native = " tar-replacement-native"
61NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
62
63BBCLASSEXTEND = "native nativesdk"