summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stress-ng/stress-ng_0.12.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/stress-ng/stress-ng_0.12.02.bb')
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.12.02.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.12.02.bb b/meta/recipes-extended/stress-ng/stress-ng_0.12.02.bb
new file mode 100644
index 0000000000..a5851b43f2
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.12.02.bb
@@ -0,0 +1,27 @@
1SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
10 file://no_daddr_t.patch \
11 "
12SRC_URI[sha256sum] = "f847be115f60d3ad7d37c806fd1bfb1412aa3c631fca581d6dc233322f50d6a5"
13
14DEPENDS = "coreutils-native"
15
16PROVIDES = "stress"
17RPROVIDES_${PN} = "stress"
18RREPLACES_${PN} = "stress"
19RCONFLICTS_${PN} = "stress"
20
21inherit bash-completion
22
23do_install() {
24 oe_runmake DESTDIR=${D} install
25 ln -s stress-ng ${D}${bindir}/stress
26}
27