summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.3.0.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.3.0.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta/recipes-extended/slang/slang_2.3.0.bb b/meta/recipes-extended/slang/slang_2.3.0.bb
index ce7b16a8f7..52b2a63a8c 100644
--- a/meta/recipes-extended/slang/slang_2.3.0.bb
+++ b/meta/recipes-extended/slang/slang_2.3.0.bb
@@ -9,7 +9,7 @@ to recode S-Lang procedures in C if you need to."
9 9
10HOMEPAGE = "http://www.jedsoft.org/slang/" 10HOMEPAGE = "http://www.jedsoft.org/slang/"
11SECTION = "libs" 11SECTION = "libs"
12DEPENDS = "pcre ncurses" 12DEPENDS = "ncurses virtual/libiconv"
13 13
14LICENSE = "GPLv2" 14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02" 15LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
@@ -20,18 +20,23 @@ SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \
20 file://fix-check-pcre.patch \ 20 file://fix-check-pcre.patch \
21 file://slang-fix-the-iconv-existence-checking.patch \ 21 file://slang-fix-the-iconv-existence-checking.patch \
22 file://0001-Fix-error-conflicting-types-for-posix_close.patch \ 22 file://0001-Fix-error-conflicting-types-for-posix_close.patch \
23 file://no-x.patch \
23 " 24 "
25SRC_URI[md5sum] = "3bcc790460d52db1316c20395b7ac2f1"
26SRC_URI[sha256sum] = "f95224060f45e0d8212a5039b339afa5f1a94a1bb0298e796104e5b12e926129"
27
24UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/" 28UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/"
25PREMIRRORS_append = "\n http://www.jedsoft.org/releases/slang/.* http://www.jedsoft.org/releases/slang/old/ \n" 29PREMIRRORS_append = "\n http://www.jedsoft.org/releases/slang/.* http://www.jedsoft.org/releases/slang/old/ \n"
26 30
27inherit autotools-brokensep 31inherit autotools-brokensep
28
29CLEANBROKEN = "1" 32CLEANBROKEN = "1"
30 33
31SRC_URI[md5sum] = "3bcc790460d52db1316c20395b7ac2f1" 34EXTRA_OECONF = "--without-onig"
32SRC_URI[sha256sum] = "f95224060f45e0d8212a5039b339afa5f1a94a1bb0298e796104e5b12e926129"
33 35
34EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib" 36PACKAGECONFIG ??= "pcre"
37PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,pcre"
38PACKAGECONFIG[png] = "--with-png,--without-png,libpng"
39PACKAGECONFIG[zlib] = "--with-z,--without-z,zlib"
35 40
36do_configure_prepend() { 41do_configure_prepend() {
37 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory 42 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory