summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/quota/quota_4.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/quota/quota_4.09.bb')
-rw-r--r--meta/recipes-extended/quota/quota_4.09.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/quota/quota_4.09.bb b/meta/recipes-extended/quota/quota_4.09.bb
new file mode 100644
index 0000000000..b779657dfc
--- /dev/null
+++ b/meta/recipes-extended/quota/quota_4.09.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem"
2SECTION = "base"
3HOMEPAGE = "http://sourceforge.net/projects/linuxquota/"
4DESCRIPTION = "Tools and patches for the Linux Diskquota system as part of the Linux kernel"
5BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136"
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \
8 file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \
11 file://fcntl.patch \
12 "
13SRC_URI[sha256sum] = "9cdaca154bc92afc3117f0e5f5b3208dd5f84583af1cf061c39baa0a2bb142f9"
14
15CVE_PRODUCT = "linux_diskquota"
16
17UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/linuxquota/files/quota-tools/"
18UPSTREAM_CHECK_REGEX = "/quota-tools/(?P<pver>(\d+[\.\-_]*)+)/"
19
20DEPENDS = "gettext-native e2fsprogs libnl dbus"
21
22inherit autotools-brokensep gettext pkgconfig
23
24CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-I${STAGING_INCDIR}/tirpc', '', d)}"
25LDFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-ltirpc', '', d)}"
26ASNEEDED = ""
27
28PACKAGECONFIG ??= "tcp-wrappers rpc bsd"
29PACKAGECONFIG:libc-musl = "tcp-wrappers rpc"
30
31PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
32PACKAGECONFIG[rpc] = "--enable-rpc,--disable-rpc,libtirpc"
33PACKAGECONFIG[bsd] = "--enable-bsd_behaviour=yes,--enable-bsd_behaviour=no,"
34PACKAGECONFIG[ldapmail] = "--enable-ldapmail,--disable-ldapmail,openldap"