summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/psmisc/psmisc_23.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/psmisc/psmisc_23.7.bb')
-rw-r--r--meta/recipes-extended/psmisc/psmisc_23.7.bb57
1 files changed, 55 insertions, 2 deletions
diff --git a/meta/recipes-extended/psmisc/psmisc_23.7.bb b/meta/recipes-extended/psmisc/psmisc_23.7.bb
index ea272cd92d..4128ca0533 100644
--- a/meta/recipes-extended/psmisc/psmisc_23.7.bb
+++ b/meta/recipes-extended/psmisc/psmisc_23.7.bb
@@ -1,9 +1,62 @@
1require psmisc.inc 1SUMMARY = "Utilities for managing processes on your system"
2HOMEPAGE = "http://psmisc.sf.net/"
3DESCRIPTION = "The psmisc package contains utilities for managing processes on your \
4system: pstree, killall and fuser. The pstree command displays a tree \
5structure of all of the running processes on your system. The killall \
6command sends a specified signal (SIGTERM if nothing is specified) to \
7processes identified by name. The fuser command identifies the PIDs \
8of processes that are using specified files or filesystems."
9SECTION = "base"
10DEPENDS = "ncurses virtual/libintl"
11
2LICENSE = "GPL-2.0-only" 12LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
4 14
5SRC_URI = "git://gitlab.com/psmisc/psmisc.git;protocol=https;branch=master \ 15SRC_URI = "git://gitlab.com/psmisc/psmisc.git;protocol=https;branch=master \
6 file://0001-Use-UINTPTR_MAX-instead-of-__WORDSIZE.patch \
7 " 16 "
8SRCREV = "9091d6dbcce3d8fb87adf9249a2eb346d25a562c" 17SRCREV = "9091d6dbcce3d8fb87adf9249a2eb346d25a562c"
9S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19
20inherit autotools gettext
21
22# Upstream has a custom autogen.sh which invokes po/update-potfiles as they
23# don't ship a po/POTFILES.in (which is silly). Without that file gettext
24# doesn't believe po/ is a gettext directory and won't generate po/Makefile.
25do_configure:prepend() {
26 ( cd ${S} && po/update-potfiles )
27}
28
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
31PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
32PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
33
34ALLOW_EMPTY:${PN} = "1"
35
36PACKAGES =+ "fuser fuser-doc killall killall-doc pstree pstree-doc"
37PACKAGES += "psmisc-extras"
38
39FILES:${PN} = ""
40RDEPENDS:${PN} = "fuser killall pstree"
41
42FILES:fuser = "${bindir}/fuser.${BPN}"
43FILES:fuser-doc = "${mandir}/man1/fuser*"
44
45FILES:killall = "${bindir}/killall.${BPN}"
46FILES:killall-doc = "${mandir}/man1/killall*"
47
48FILES:pstree = "${bindir}/pstree"
49FILES:pstree-doc = "${mandir}/man1/pstree*"
50
51FILES:psmisc-extras = "${bindir}"
52FILES:psmisc-extras-doc = "${mandir}"
53
54inherit update-alternatives
55
56ALTERNATIVE_PRIORITY = "90"
57
58ALTERNATIVE:killall = "killall"
59
60ALTERNATIVE:fuser = "fuser"
61
62ALTERNATIVE:pstree = "pstree"