summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pigz/pigz_2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pigz/pigz_2.8.bb')
-rw-r--r--meta/recipes-extended/pigz/pigz_2.8.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-extended/pigz/pigz_2.8.bb b/meta/recipes-extended/pigz/pigz_2.8.bb
new file mode 100644
index 0000000000..fcf0c93e41
--- /dev/null
+++ b/meta/recipes-extended/pigz/pigz_2.8.bb
@@ -0,0 +1,48 @@
1SUMMARY = "A parallel implementation of gzip"
2DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \
3fully functional replacement for gzip that exploits multiple processors and \
4multiple cores to the hilt when compressing data. pigz was written by Mark \
5Adler, and uses the zlib and pthread libraries."
6HOMEPAGE = "http://zlib.net/pigz/"
7SECTION = "console/utils"
8LICENSE = "Zlib & Apache-2.0"
9LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21"
10
11SRC_URI = "http://zlib.net/${BPN}/fossils/${BP}.tar.gz"
12SRC_URI[sha256sum] = "eb872b4f0e1f0ebe59c9f7bd8c506c4204893ba6a8492de31df416f0d5170fd0"
13PROVIDES:class-native += "gzip-native"
14
15# Point this at the homepage in case /fossils/ isn't updated
16UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/"
17UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar"
18
19DEPENDS = "zlib"
20
21EXTRA_OEMAKE = "-e MAKEFLAGS="
22
23inherit update-alternatives
24
25do_install() {
26 # Install files into /bin (FHS), which is typical place for gzip
27 install -d ${D}${base_bindir}
28 install ${B}/pigz ${D}${base_bindir}/pigz
29 ln -nsf pigz ${D}${base_bindir}/unpigz
30 ln -nsf pigz ${D}${base_bindir}/pigzcat
31}
32
33do_install:append:class-native() {
34 install -d ${D}${bindir}
35 install ${B}/pigz ${D}${bindir}/gzip
36 ln -nsf gzip ${D}${bindir}/gunzip
37 ln -nsf gzip ${D}${bindir}/zcat
38}
39
40ALTERNATIVE_PRIORITY = "110"
41ALTERNATIVE:${PN} = "gunzip gzip zcat"
42ALTERNATIVE:${PN}:class-nativesdk = ""
43ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
44ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
45ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
46ALTERNATIVE_TARGET = "${base_bindir}/pigz"
47
48BBCLASSEXTEND = "native nativesdk"