summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.6.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.6.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.6.bb b/meta/recipes-extended/parted/parted_3.6.bb
new file mode 100644
index 0000000000..a537ef74db
--- /dev/null
+++ b/meta/recipes-extended/parted/parted_3.6.bb
@@ -0,0 +1,62 @@
1SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3DESCRIPTION = "GNU Parted manipulates partition tables. This is useful for creating space for new operating systems, reorganizing disk usage, copying data on hard disks and disk imaging."
4LICENSE = "GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
6SECTION = "console/tools"
7DEPENDS = "ncurses util-linux virtual/libiconv"
8
9SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
10 file://fix-doc-mandir.patch \
11 file://0001-fs-Add-libuuid-to-linker-flags-for-libparted-fs-resi.patch \
12 file://autoconf-2.73.patch \
13 file://run-ptest \
14 "
15
16SRC_URI[sha256sum] = "3b43dbe33cca0f9a18601ebab56b7852b128ec1a3df3a9b30ccde5e73359e612"
17
18inherit autotools pkgconfig gettext texinfo ptest
19
20PACKAGECONFIG ?= "readline"
21PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,libdevmapper lvm2"
22PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
23
24BBCLASSEXTEND = "native nativesdk"
25
26do_compile_ptest() {
27 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags
28}
29
30do_install_ptest() {
31 t=${D}${PTEST_PATH}
32 mkdir $t/build-aux
33 cp ${S}/build-aux/test-driver $t/build-aux/
34 cp -r ${S}/tests $t
35 cp ${B}/tests/Makefile $t/tests/
36 mkdir $t/lib
37 cp ${B}/lib/config.h $t/lib
38 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
39 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
40 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
41 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = "${PTEST_PATH}"|g" $t/tests/Makefile
42 sed -i "s|^abs_top_builddir =.*|abs_top_builddir = "${PTEST_PATH}"|g" $t/tests/Makefile
43 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
44 sed -i "/^BUILDINFO.*$/d" $t/tests/Makefile
45 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
46 do cp ${B}/tests/.libs/$i $t/tests/; \
47 done
48 sed -e 's| ../parted||' -i $t/tests/*.sh
49}
50
51RDEPENDS:${PN}-ptest = "bash coreutils perl util-linux-losetup util-linux-mkswap python3 make gawk e2fsprogs-mke2fs e2fsprogs-tune2fs python3-core dosfstools"
52RRECOMMENDS:${PN}-ptest += "kernel-module-scsi-debug kernel-module-loop kernel-module-vfat"
53RDEPENDS:${PN}-ptest:append:libc-glibc = "\
54 glibc-utils \
55 locale-base-en-us \
56 "
57
58inherit update-alternatives
59
60ALTERNATIVE_PRIORITY = "100"
61ALTERNATIVE:${PN} = "partprobe"
62ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"