summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.4.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.4.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.4.bb b/meta/recipes-extended/pam/libpam_1.1.4.bb
new file mode 100644
index 0000000000..59fbdcdffc
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam_1.1.4.bb
@@ -0,0 +1,85 @@
1SUMMARY = "Linux-PAM (Pluggable Authentication Modules)"
2DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), Basically, it is a flexible mechanism for authenticating users"
3HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/"
4BUGTRACKER = "http://sourceforge.net/projects/pam/support"
5SECTION = "base"
6# PAM is dual licensed under GPL and BSD.
7# /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time
8# libpam-runtime-1.0.1 is GPLv2+), by openembedded
9LICENSE = "GPLv2+ | BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
11
12PR = "r0"
13
14DEPENDS = "bison flex cracklib"
15RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
16RDEPENDS_${PN}-xtests = "libpam pam-plugin-access pam-plugin-debug pam-plugin-cracklib pam-plugin-pwhistory \
17 pam-plugin-succeed-if pam-plugin-time coreutils"
18RRECOMMENDS_${PN} = "libpam-runtime"
19
20SRC_URI = "${KERNELORG_MIRROR}/linux/libs/pam/library/Linux-PAM-${PV}.tar.bz2 \
21 file://99_pam \
22 file://pam.d/* \
23 file://libpam-xtests.patch"
24
25SRC_URI_append_libc-uclibc = " file://pam-no-innetgr.patch"
26
27SRC_URI[md5sum] = "e9af5fb27bb22edb55d077e2888b3ebc"
28SRC_URI[sha256sum] = "ccd89331914390b1e9e99c954471d65f19b660d81e15a46eeb96cee125d44056"
29
30EXTRA_OECONF = "--with-db-uniquename=_pam \
31 --includedir=${includedir}/security \
32 --libdir=${base_libdir} \
33 --disable-regenerate-docu"
34CFLAGS_append = " -fPIC "
35
36S = "${WORKDIR}/Linux-PAM-${PV}"
37
38inherit autotools gettext
39
40PACKAGES += "${PN}-runtime ${PN}-xtests"
41FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"
42FILES_${PN}-dbg += "${base_libdir}/security/.debug \
43 ${base_libdir}/security/pam_filter/.debug"
44FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}"
45FILES_${PN}-runtime = "${sysconfdir}"
46FILES_${PN}-xtests = "${datadir}/Linux-PAM/xtests"
47
48PACKAGES_DYNAMIC += " pam-plugin-*"
49
50python populate_packages_prepend () {
51 import os.path
52
53 def pam_plugin_append_file(pn, dir, file):
54 nf = os.path.join(dir, file)
55 of = bb.data.getVar('FILES_' + pn, d, True)
56 if of:
57 nf = of + " " + nf
58 bb.data.setVar('FILES_' + pn, nf, d)
59
60 dvar = bb.data.expand('${WORKDIR}/package', d, True)
61 pam_libdir = bb.data.expand('${base_libdir}/security', d)
62 pam_sbindir = bb.data.expand('${sbindir}', d)
63 pam_filterdir = bb.data.expand('${base_libdir}/security/pam_filter', d)
64
65 do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
66 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_chkpwd')
67 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_update')
68 pam_plugin_append_file('pam-plugin-tally', pam_sbindir, 'pam_tally')
69 pam_plugin_append_file('pam-plugin-tally2', pam_sbindir, 'pam_tally2')
70 pam_plugin_append_file('pam-plugin-timestamp', pam_sbindir, 'pam_timestamp_check')
71 pam_plugin_append_file('pam-plugin-mkhomedir', pam_sbindir, 'mkhomedir_helper')
72 do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
73}
74
75do_install() {
76 autotools_do_install
77
78 # don't install /var/run when populating rootfs. Do it through volatile
79 rm -rf ${D}/var
80 install -d ${D}${sysconfdir}/default/volatiles
81 install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
82
83 install -d ${D}${sysconfdir}/pam.d/
84 install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
85}