summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.24.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.24.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.24.bb b/meta/recipes-extended/newt/libnewt_0.52.24.bb
new file mode 100644
index 0000000000..1e39a1c5ca
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.24.bb
@@ -0,0 +1,56 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPL-2.0-only"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt python3"
19
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
21 file://cross_ar.patch \
22 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
23 file://0001-detect-gold-as-GNU-linker-too.patch \
24 "
25
26SRC_URI[sha256sum] = "5ded7e221f85f642521c49b1826c8de19845aa372baf5d630a51774b544fbdbb"
27
28S = "${WORKDIR}/newt-${PV}"
29
30inherit autotools-brokensep python3native python3-dir python3targetconfig
31
32EXTRA_OECONF = "--without-tcl --with-python"
33
34EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
35
36CLEANBROKEN = "1"
37
38export CPPFLAGS
39
40PACKAGES:prepend = "whiptail ${PN}-python "
41
42RDEPENDS:${PN}-python += "python3-core"
43FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
44
45do_configure:prepend() {
46 sh autogen.sh
47}
48
49do_compile:prepend() {
50 # Make sure the recompile is OK
51 rm -f ${B}/.depend
52}
53
54FILES:whiptail = "${bindir}/whiptail"
55
56BBCLASSEXTEND = "native nativesdk"