summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.20.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.20.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.20.bb b/meta/recipes-extended/newt/libnewt-python_0.52.20.bb
deleted file mode 100644
index 433d184c71..0000000000
--- a/meta/recipes-extended/newt/libnewt-python_0.52.20.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1require recipes-extended/newt/libnewt_${PV}.bb
2
3SUMMARY .= " - python"
4DEPENDS = "libnewt python3"
5RDEPENDS_${PN} += "python3-core"
6
7inherit python3native python3-dir
8
9EXTRA_OECONF += "--with-python"
10EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
11
12
13do_compile () {
14 VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
15 oe_runmake _snack.so
16}
17
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
20 install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
21 install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
22}
23
24PACKAGES_remove = "whiptail"
25
26FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
27
28BBCLASSEXTEND = "native nativesdk"